Mikrotik, маршрутизация, несколько каналов и т.д.

Все о специализированных сетевых программных продуктах
Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 27 янв 2010, 13:04

Эх даже эксперимент провел, всё работает.... смотрим картинки
Комментарии в названиях файлов.
Вложения
1Тестирую скорость.JPG
1Тестирую скорость.JPG (24.44 Кб) Просмотров: 14397
2создаю правило, ограничиваю скорость 2 мбита.JPG
2создаю правило, ограничиваю скорость 2 мбита.JPG (23.22 Кб) Просмотров: 14390
3Опять тестирую скорость.JPG
3Опять тестирую скорость.JPG (24.49 Кб) Просмотров: 14334
4Создаю правило на бесплатный ресурс, марка от балды.JPG
4Создаю правило на бесплатный ресурс, марка от балды.JPG (21.58 Кб) Просмотров: 14384
5Опять тестирую скорость на бесплатный ресурс.JPG
5Опять тестирую скорость на бесплатный ресурс.JPG (27.33 Кб) Просмотров: 14360

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 27 янв 2010, 13:06

6 вложений не влезает в сообщение =) вот, тестирую скорость на любой другой ресурс
Вложения
6тестирую скорость на любой другой ресурс.JPG

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 27 янв 2010, 13:55

ок!
я так думаю и у меня может это получится... но ты метишь пакеты с локальной сети и на один канал интернета,
я так понимаю...
у меня они тоже метятся на каждую группу и работает шейпер...
но у меня немного другое...
групп то несколько и каналов интернета тоже несколько... например группа А метим пакеты и направляем ее
на провайдера номер 1, а ресурсы то лежат на провайдере номер 3...
вот эти правила я так понимаю должны это делать:
Код: Выделить всё
add action=mark-routing chain=prerouting comment="" disabled=no \
    dst-address-list=wlc new-routing-mark=Limit_01 passthrough=no
add action=mark-packet chain=forward comment="" disabled=no dst-address-list=\
    wlc new-packet-mark=wlc-packet passthrough=no

wlc- это список без платных ресурсов из адрес листа.
но направлять они направляют, только трафик на некоторых группах из адрес листа
попадает под шейпер, а почему я писал выше, по тому что у меня есть резервные метки пакетов,
и когда работает пере-направление пакеты попадают под эти метки...
если отключить эти доп. метки то все работает....
вот я и спрашивал может что то в первых двух правилах что то не так...
адреса вбиты в dst-address-list.... а если их вбивать как ты предлагаешь в src-address-list то вообще не
работает...

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 27 янв 2010, 14:16

sherwood писал(а):ок!
я так думаю и у меня может это получится... но ты метишь пакеты с локальной сети и на один канал интернета,
я так понимаю...

Неправильно понимаешь, канала 3, шейпер на внешку, шейпер на городские ресурсы, шейпер для подключения через vpn с wifi и т.п.

sherwood писал(а):групп то несколько и каналов интернета тоже несколько... например группа А метим пакеты и направляем ее
на провайдера номер 1, а ресурсы то лежат на провайдере номер 3...

А причем тут вообще chain: prerouting ? для шейпера ты пакеты метишь в forward как я понял.
У меня, как ты можешь заметить, тоже куча правил, только какая нафиг разница, если правило в мангле, стоит выше с passtrogh=no?...

sherwood писал(а):а если их вбивать как ты предлагаешь в src-address-list то вообще не
работает...

А куда же вбивать, есди пакеты идут с удаленного хоста а не на него?...


Не работает? извиняй тогда, объяснял как мог, в картинках, если все сделал правильно, а не работает, значит для твоего случая не подходит, ищи альтернативу.

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 27 янв 2010, 14:43

хорошо...
ты на сколько я понял сделал без платные ресурсы сайт 2ip.ru?
но он доступен на всех каналах интернета.... поэтому тут нет вопросов...
тогда покажи мне тупому, правила которые направят этот компьютер с которого ты делал замеры скорости
на первый канал интернета (например, или на тот через который он выходит), а на сайт 2ip.ru без ограничения по
скорости выходить через например второй канал...
и можно полностью посмотреть правило, где ты метишь его меткой Dugaga?

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 27 янв 2010, 16:04

Метка по которой он рутится на другой канал в CHAIN: PREROUTING метка по которой режется скорость в CHAIN: FORWARD на друг друга они вообще не влияют, можно поставить входящий интерфейс соответствующий в правиле, хотя у меня работает без этого.
sherwood писал(а):и можно полностью посмотреть правило, где ты метишь его меткой Dugaga?

Метка Bugaga это черезвычайно важно.
Правило уже удалил, лезть опять на сервер лень, в правиле было chain: forward, в src. address адрес 2ip.ru и action: mark packet, passtrough=no... всё что там было.

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 27 янв 2010, 17:07

вот попробовал просто сделать маркировку на 2ip.ru, что бы она не попала под шейпер:
Код: Выделить всё
/ip firewall mangle
add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=free passthrough=no src-address=188.40.74.10

пакеты метятся, но скорость согласно шейперу:
Изображение

правила в шейпере для компьютера с которого пробовал:
Код: Выделить всё
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=1024_download packet-mark=1024_down parent=ether4 \
    priority=8 queue=1024_down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=1024_upload packet-mark=1024_upl parent=global-out \
    priority=8 queue=1024_upl


получается что у меня пофиг почему то все маркировки пакетов, они все равно попадают под шейпер...
хорошо... я понял, что так я не решу наверное проблему, какие то правила у меня наверное работают не правильно,
а может быть работают правильно но что мне нужно еще Микротик уже не может, я имею ввиду про маркировку пакетов на запасных интерфейсах...
может тогда подскажете где за оплату могут решить такие вопросы?
Разработчики, говорят что они не занимаются этим :) странно как то у них поддержка работает....
у меня есть DLink 3526 так при затруднениях, либо по телефону либо по почте обязательно решат вопрос,
ни когда с ними не было проблем...потому что в мануале не напишешь всех ситуаций которые могут возникнуть
у пользователей..
а тут написали простенький мануальчик, добавили примерчиков, и дальше разбирайтесь сами...
пишешь им что не получается ... ответ - мы не помогаем в настройке своего оборудования :D ... круто...

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 27 янв 2010, 18:01

Помогают, проверено, когда есть конкретный вопрос, а так... получается купил машину у Opel и разбираю с конструкторами как ехать на таком то перекрестке в моем городе... :loll:

Бррр, у тебя по марке prerouting пакеты рулятся на разные каналы, chain: forward ...

/ip firewall mangle
add action=mark-packet chain=prerouting comment="" disabled=no \
new-packet-mark=free passthrough=no src-address=188.40.74.10

а надо Forward

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 27 янв 2010, 18:44

спасибо....
всего то надо было одну строчку показать...
если бы я знал как правильно задать вопрос я наверное и сам бы разобрался...
теперь работает... с сайтом...
с без платными ресурсами позже буду разбираться...

Бррр, у тебя по марке prerouting пакеты руляться на разные каналы, chain: forward ...


а что их можно рулить как то еще? и не понятно что имелось ввиду после запитой - chain: forward?
это нужно рулить с помощью chain: forward? или еще что?
тогда подскажи в двух словах так сказать на "пальцах",
когда используется - prerouting ... когда - forward, что означает - passthrough когда нужно nо а когда yes...
как связаны prerouting и forward есть какие то правила по их использованию?

P.S.
и с авто ты немного не угадал...
автомобиль продается готовый к использованию, а это оборудование пустое...
то есть представь ты купил авто а у него не накачены шины, не отрегулировано зажигание, не отрегулированы
фары, не сбалансированы колёсы, не отрегулирован сход-развал, не отрегулированы клапана (у некоторых моделях),
не отрегулирована АКПП и т.д....
в принципе ездить будет как то :D а дальше как все это настроить твоя забота ...
и вот ты звонишь на завод изготовитель и говоришь что включаю на коробки первую передачу а она у меня едет
назад ... и к тому же не развивает полную мощь....
а тебе и говорят мы не помогаем своим пользователям в настройке СВОЕГО авто, пишите на форумы...
и вот ты на форуме ... и там тебе советуют подтяни там подкрути там, но так как у тебя нет в этом опыта то и
ни чего может и не получится ... а тебе пишут что у них все работает...
печально все это....
ну как то так... :)

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 27 янв 2010, 19:59

sherwood писал(а):спасибо....
всего то надо было одну строчку показать...

Дааа, не туда показывали, вроде как в нескольких последних сообщениях писал chain: forward ....

sherwood писал(а):теперь работает... с сайтом...
с без платными ресурсами позже буду разбираться...

С ресурсами так же в принципе тока address-list =)

sherwood писал(а):это нужно рулить с помощью chain: forward? или еще что?
тогда подскажи в двух словах так сказать на "пальцах",
когда используется - prerouting ... когда - forward, что означает - passthrough когда нужно nо а когда yes...


Ну, во первых надо показать пакетам на какой канал идти, для этого мы в цепочке prerouting(наверное означает "до рутинга" =) задаем mark routing, в рутах задаем пакеты с какой маркой идут на данный канал, а есть chain forward, это пакеты которые проходят через рутер тут та мы их и шейпим =) passtrough разрешает или запрещает промаркированному пакету идти дальше по правилам мангла..

sherwood писал(а):и с авто ты немного не угадал...
автомобиль продается готовый к использованию, а это оборудование пустое...

Вот установи какой нить линух или фрибсд и понастраивай там нат, шейпер... поймешь, что микротик это готовая настроенная ось, осталось вставить ключ в зажигание ввести место куда хочешь ехать в GPS....но газ, тормоз и руль крутить, это уже твоя задача 8)

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 27 янв 2010, 23:12

фу ... вроде получилось ... ура .... спасибо человеческое...
Код: Выделить всё
add action=mark-routing chain=prerouting comment="" disabled=no \
    dst-address-list=wlc new-routing-mark=wlc_rout passthrough=no
add action=mark-packet chain=forward comment="" disabled=no new-packet-mark=\
    wlc-packet passthrough=no src-address-list=wlc

сделал эти правила и все заработало....
если можешь прокомментируй мне их, а именно почему мы то есть я в mark-routing указываю dst-address-list?
(если указывать src-address-list - то не работает ... доступа вообще нет на сайты)...
а в mark-packet я указываю src-address-list?...
просто ни как не могу усвоить что такое src-address а что dst-address...

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 28 янв 2010, 00:32

src. = источник dst. = цель
Первое правило "chain prerouting" метит маркой пакеты на определенный dst. address-list т.е. исходящие соединения на определенные адреса идут на интерфейс такой та, по этому указываем цель(dst.), естественно на тот же интерфейс тебе и ответят.

Второе правило "chain forward" метит пакеты проходящие через рутер от определенного хоста, т.е. источника(src), по этому указываем src. address-list

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 28 янв 2010, 12:19

KirillTs писал(а):passtrough разрешает или запрещает промаркированному пакету идти дальше по правилам мангла..


у меня вот по этому примеру промаркированы маршруты:
http://wiki.mikrotik.com/wiki/Load_Balancing_over_Multiple_Gateways
и там указано - passtrough NO, но после этих правил дальше маркируются пакеты для шейпера,
получается что надо ставить YES? или маркировка маршрутов и пакетов ни как не связана?
и можно какой ни будь примерчик для понимания, где пакеты с начало маркируются для одних целей,
а потом еще для чего нибудь....

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 28 янв 2010, 13:06

Цепочки разные......все таки посмотри на packet flow с Wiki, я давал ссылку....

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 28 янв 2010, 13:41

хорошо... там много не понятного...
подскажи для примера, например: http://wiki.mikrotik.com/wiki/Load_Balancing_over_Multiple_Gateways
как по этим схемам пойдет цепочка?
то есть по первой или по второй схеме... ни как не разберусь, нужен пример...
сначала INPUT INTERFACE -> IN-INTERFACE BRIDGE (у меня бриджа нет значит NO) -> PREROUTING
как дальше?
и INPUT это вход с интернет канала или с локальной сети?

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 28 янв 2010, 14:17

http://wiki.mikrotik.com/wiki/Packet_Fl ... _interface
:hmm: Ну смотрим на схему Input, с начала prerouting, forward, src.nat(где то тут =), queue(HTB, queue tree)...вроде так, лекция состоится в ДК железнодорожников 32 Мая :D

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 28 янв 2010, 21:36

сами туда поедете? :D
понятно... потом будем додумывать...
еще вопрос: в file есть такие файлы: autosupout.old.rif, autosupout.rif
что это за файлы и можно ли их удалить?

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 28 янв 2010, 21:42

Watchdog эти файлы геренирует при сбоях софта, только открыть их самому нельзя, только посылать разработчикам...

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 31 янв 2010, 14:10

хочу заново настроить это оборудование, то есть резетнуть, есть некоторые баги..
восстановление из бекапа не помогает, баг тоже восстанавливается...
что хочу спросить:
как мне быстро записать все правила?
то есть если я сначала сделаю export разделов и потом телнетом заганю их все,
например все 40 правил мангла такого плана:
Код: Выделить всё
add action=mark-routing chain=prerouting comment="" disabled=no \
    dst-address-list=wlc new-routing-mark=wlc_rout passthrough=no
add action=mark-packet chain=forward comment="" disabled=no new-packet-mark=\
    wlc-packet passthrough=no src-address-list=wlc

то они запишутся или все равно придется по одному вводить?

Аватара пользователя
Igoras
Moderator
Moderator
 
Сообщения: 3248
Зарегистрирован:
22 окт 2003, 20:27
Откуда: Кишинев, Starushka.net

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение Igoras 31 янв 2010, 15:33

вообще-то у экспорта как ни странно есть противоположная по функции команда import ;) ну а через телнет тоже запишутся...

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 01 фев 2010, 14:42

есть еще вопрос:
как направить исходящую почту, которую отсылают пользователи локальной сети с помощью The Bat и т.д.
то есть почтовыми клиентами на определенный канал?
дело в том два из трех провайдеров блокируют это, а третий канал это позволяет...
понимаю что в мангле надо сделать правило prerouting - src.address (вся сеть например 172.16.0.0/24)- mark routing
далее наверное надо выбрать протокол smtp и порт 25, но там такого вроде нет протокола...
или у меня совсем все не так?

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 01 фев 2010, 14:47

А попробовать лень?
Выбирай протокол tcp и порт 25 не ошибешься =)

Аватара пользователя
sherwood

 
Сообщения: 140
Зарегистрирован:
11 дек 2009, 10:25

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение sherwood 01 фев 2010, 15:24

нет не лень, на ура не получилось, смутило отсутствие протокола...
уря ... заработало...
только не сразу... спутал src порт с dst порт...

Аватара пользователя
KirillTs

 
Сообщения: 962
Зарегистрирован:
11 дек 2006, 11:29

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение KirillTs 01 фев 2010, 16:18

sherwood писал(а):смутило отсутствие протокола...

Так гугль знает все, первая ссылка SMTP =)
Семейство:

TCP/IP

Аватара пользователя
Igoras
Moderator
Moderator
 
Сообщения: 3248
Зарегистрирован:
22 окт 2003, 20:27
Откуда: Кишинев, Starushka.net

Re: Mikrotik, маршрутизация, несколько каналов и т.д.

Сообщение Igoras 01 фев 2010, 22:53

smtp - протокол не того уровня... его скорее в порт нужно писать :) Хотя МТ буквенных названий не поддерживает :)

Пред.След.

Вернуться в Сетевое программное обеспечение

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0

cron